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Chapter 1. Your First Groundwater Model with PM 

This tutorial provides an overview of the modeling process with Processing Modflow (PM), 

describes the basic skills you need to use PM, and takes you step by step through a hypothetical 

problem. Before getting started with the tutorial, you should be familiar with the Main Window 

of PM as described in Section 1.2 of PM’s User Guide.  

PM requires the use of consistent units throughout the model. For example, if you are using 

length [L] units of meters and time [T] units of seconds, hydraulic conductivity will be expressed 

in units of [m/s] and pumping rates will be in units of [m3/s]. The values of the simulation results 

are also expressed in the same units. Inconsistent units may be used for concentration values. 

For example, you may use mg/Liter in a model with the length unit of m. In this case, the 

calculated concentration will be expressed in mg/Liter and the calculated mass (= volume x 

concentration) will be expressed in [m3 · mg/Liter]. 

1.1. Overview of the Hypothetical Problem 

As shown in Figure 1, an aquifer system with two stratigraphic units is bounded by no flow 

boundaries on the North and South sides. The West and East sides are bounded by rivers, which 

are in full hydraulic contact with the aquifer and can be considered as fixed head boundaries. The 

hydraulic heads on the west and east boundaries are 9 m and 8 m above reference level, 

respectively. A pumping well is located to the east of the contaminated area. The well is screened 

over the entire aquifer system. 

 

Figure 1. Configuration of the hypothetical model 
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The model parameters are as follows. 

1. The aquifer system is unconfined and isotropic.  
2. The horizontal hydraulic conductivities of the first and second stratigraphic units are 

0.0001 m/s and 0.0005 m/s, respectively.  
3. Vertical hydraulic conductivity of both units is assumed to be 10 percent of the horizontal 

hydraulic conductivity.  
4. The effective porosity is 0.25.  
5. The elevation of the ground surface (top of the first stratigraphic unit) is 10m. The 

thickness of the first and the second units is 4 m and 6 m, respectively.  
6. A constant recharge rate of 8 x 10-9 m/s is applied to the aquifer.  
7. A contaminated area lies in the first unit next to the west boundary. The exact location of 

the area is included in the shapefile area.shp that is installed in the Tutorial11 folder.  

A numerical model needs to be developed for this site to calculate the required pumping rate of 

the well under the steady-state condition. The pumping rate must be high enough so that the 

contaminated area lies within the capture zone of the pumping well. 

We will use PM to construct the numerical model and use MODPATH to compute the capture 

zone of the pumping well. We will show how to use PEST to calibrate the steady-state flow model. 

We will demonstrate the use of MT3D to simulate the solute transport process. 

1.2. Spatial Discretization of the Model Domain 

In MODFLOW, an aquifer system is replaced by a discretized domain consisting of an array of 

nodes and associated finite difference blocks (cells). Figure 2 shows the spatial discretization 

scheme of Modflow with a mesh of 

cells and nodes at which hydraulic 

heads are calculated. The nodal grid 

forms the framework of the 

numerical model. Hydrostratigraphic 

units can be represented by one or 

more model layers. The thickness of 

each model cell and the width of 

each column and row may be 

variable.  

PM uses the index notation [Layer, 

Row, Column] to describe the 

location of a cell in a 3D array. For 

example, the cell located in the first 

 
1 The Tutorial1 folder is installed in C:\Users\YourUserName\Documents\My Processing Modflow Models\ 

Figure 2. Spatial discretization of Modflow 
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layer, 6th row, and 2nd column is denoted by [1, 6, 2]. For 2D arrays, the index notation [Row, 

Column] is used. 

In this example, the model domain will be discretized in cells of horizontal dimensions of 20m by 

20m. The first stratigraphic layer is represented by the first model layer and the second 

stratigraphic layer is represented by two model layers. It is to note that a higher resolution in the 

vertical direction is often required to properly simulate the vertical migration of contaminants. 

1.3. Build and Run a Steady-State Flow Model 

In this section, we will walk you through the following steps to build your first groundwater model 

with PM.  

1. Create a groundwater model and load the area.shp shapefile, 
2. Specify layer types, 
3. Modify the layer elevation of the model cells, 
4. Assign cell types, such as constant-head or no-flow cells, to the flow model, 
5. Assign the initial hydraulic head values, and aquifer parameters, such as hydraulic 

conductivity, to model cells,  
6. Add the pumping well to the model, and 
7. Carry out the flow simulation with MODFLOW. 

➢ To create a new model 

1. Start PM if it is not already started and select File > New to start a new project.   
2. Turn off the maps by unchecking the Base Maps group on the Table of Contents (TOC), as 

we will not use the base map feature in this tutorial.  
3. Select File > Create Model.  

• PM displays a dialog box and asks you to save the project before creating a model, 
click OK on the dialog box.  

• In the Save As dialog box, create or find a folder (for example, C:\MyModels), enter a 
filename for the PM file, and then click Save. 

4. As soon as the file is saved, the Create Model dialog box appears. We use the Time tab 
(Figure 3) to define the temporal discretization and use the and Grid tab (Figure 4)  to 
define the spatial discretization of the model. All values may later be modified when 
necessary. For this tutorial, the following values are used. The default values are used if 
they are not mentioned below. 

• Internal Flow Package: Layer-Property Flow (LPF). 

• Time Tab (Figure 3): 

o Model Start Date/Time: 2018-01-01 00:00:00 

o Length of simulation = 94672800 and Time Unit = Second (that is about 3 years.) 
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• Grid Tab (Figure 4): 

o Length Unit = Meter. 

o Number of rows = 30; Number of columns = 30; Number of Layers = 3 (we use 

model layer 1 to represent the first stratigraphic unit, and model layers 2 and 3 to 

represent the second stratigraphic unit), 

o Total Width of Rows = 600.0, 

o Total Width of Columns = 600.0 (instead of 580 m, because MODFLOW counts the 

distance between the center of the cells of the constant-head boundaries), 

o Total Thickness of Layers = 10. 

o Latitude = 33.67 and Longitude = -117.75. Latitude and Longitude are the 

coordinates of the upper-left corner of the model grid. Positive latitude is in 

Northern Hemisphere, and negative latitude is Southern Hemisphere. Positive 

longitude is Eastern Hemisphere, while negative longitude is Western 

Hemisphere. You should place the model in its actual geographical location so that 

it will correctly align with base maps, observation points, and/or any shapefiles 

that you might have. Also remember that geo-reference parameters do not affect 

the widths of model rows/columns. 

Figure 3. The Time tab of the Create Model dialog box 
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5. Click OK. A model is created, a model item is added to the Models group on the TOC2, and 
the model grid is displayed on the Map Viewer.   

• You may click on a grid cell to move the grid cursor (shaded in yellow by default) to 
that cell. The location and default properties of that cell are displayed in the 
Properties window.  

• When the mouse cursor hovers above the model grid, the coordinates and cell 
location of the mouse cursor are displayed on the status bar of PM’s main window. 

6. Follow the following steps to rename the newly created model item from “Model” to 
“Tutorial1”: 

• Click on the model item on the TOC.  

• In the Settings window, double-click on the name “Model”, type “Tutorial1”, then 
press Enter to complete editing.  

• The text string for Model ID in the Settings window is the unique identifier of the 
model and is used as the name of the model data folder where the generated model 
input/output files are saved. The model data folder resides in the folder where the 
PM file is located. If Model ID is changed, PM will ask whether you want to rename 
the model data folder. 

➢ To load a reference map 

1. Right click on Shapefiles on the TOC, and then select Add to bring up the Open File dialog 
box. 

 
2 the newly added model item on the TOC will be highlighted (in yellow) meaning that it is the Active model. The 
Discretization, Parameters, and Models menus only act on the active model. 

Figure 4. The Grid tab of the Create Model dialog box 
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2. Select the file area.shp from the Tutorial1 folder, and then click Open. The shapefile is 
displayed on the Map Viewer.  

3. Uncheck the Pickable box in the Settings window of the shapefile. 

➢ To specify the layer types 

1. Select Discretization > Layer Property to display the Layer Property dialog box (Figure 5). 
By default, all model layers are convertible between confined and unconfined. MODFLOW 
handles a cell in a convertible layer in the following manner: 

• The cell is confined if the hydraulic head in the cell is higher than its top elevation,  

• The cell is unconfined if the hydraulic head in the cell lies between its bottom and top 
elevation, 

• The cell is dry if the hydraulic head in the cell is lower than its bottom elevation. 

2. Click OK to accept the default settings and close the dialog box. 

➢ To specify the elevation of the top of model layers 

1. Select Discretization > Layer Top Elevation to activate the Data Editor.  
2. Move to the first layer (by pressing Shift-PgUp or by using the  button on the Toolbar). 
3. Select Tools > Data > Reset (or press Ctrl + R). The Reset – Aquifer Parameter dialog box 

appears.  
4. Enter 10 in that dialog box, then click OK. The elevation of the top of the first layer is set 

to 10.  
5. Move to the second layer (by clicking the  button on the toolbar) and repeat steps 3 

and 4 to set the top of the second layer to 6. 
6. Move to the third layer and repeat steps 3 and 4 to set the top of the third layer to 3. 
7. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To specify the elevation of the bottom of model layers 

1. Select Discretization > Layer Bottom Elevation to activate the Data Editor.  
2. Repeat the same procedure as described above to set the bottom elevation of the first, 

second and third layers to 6, 3 and 0, respectively. 
3. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

Figure 5. The Layer Property dialog box 
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➢ To assign cell types to the flow model 

MODFLOW uses the IBOUND array, which contains a value for each model cell, to define the cell 

types. A positive value in the IBOUND array defines a variable-head (i.e., active) cell where the 

hydraulic head is computed, a negative value defines a constant head cell, and the value 0 defines 

a no-flow cell (i.e., inactive) cell. It is recommended to use 1 for variable-head cells, 0 for no-flow 

cells and -1 for constant head cells. There is no flux between the model and the world outside of 

the model, unless constant-head, specified flux, or head-dependent boundaries are defined. For 

example, specified flux boundaries may be simulated by the Recharge, Well, and Flow and Head 

Boundary packages. Head-dependent boundary conditions may be simulated with the Drain, 

General-Head Boundary, River, Stream, Lake, and Reservoir packages. Follow the steps below to 

assign the values to the IBOUND array. 

1. Select Discretization > IBOUND (Flow) to activate the Data Editor. 
2. Move to the first layer (by pressing Shift-PgUp or by using the  button on the Toolbar). 
3. Move the grid cursor to the upper-left cell [1, 1, 1] by clicking on this cell, and then press 

the Enter key to display the IBOUND (Flow Model) dialog box. 
4. Enter -1 in the dialog box, then click OK. 
5. Now, turn on the Copy Cell Data function by clicking on the  button on the toolbar (to 

turn off the function, click the  button again). When the function is on (i.e., the  button 
is depressed), the current cell value will be copied to all cells passed by the grid cursor.  

6. Press and hold the down arrow key ↓ to move the grid cursor from the cell [1, 1, 1] to the 
cell [1, 30, 1] on the lower-left corner of the model grid. The value of -1 has now been 
copied to all cells on the west side of the model. 

7. Click the cell [1, 1, 30] on the upper-right corner of the model grid to move the grid cursor 
to that cell. 

8. Press and hold the down arrow key ↓ to move the grid cursor from the cell [1, 1, 30] to 
the cell [1, 30, 30]. The value of -1 has now been copied to all cells on the east side of the 
model. 

9. Turn on the Copy Layer Data function by clicking on the  button. When you move to 
another layer while this function is on (i.e., the  button is depressed), the cell values of 
the current layer will be copied to the destination layer. To turn off the Copy Layer Data 
function, click the  button again. 

10. Move to the second layer and then to the third layer (by clicking the  button on the 
toolbar).  

11. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes.  

➢ To specify the starting hydraulic head values 

1. Select Parameters > Starting Hydraulic Head to activate the Data Editor. 
2. Move to the first layer. 
3. Select Tools > Data > Reset (or press Ctrl + R) and enter 8 in the dialog box, then click OK.  
4. Move the grid cursor to the cell [1, 1, 1] and press the Enter key (or right-click on that cell) 

to display a Starting Hydraulic Head dialog box. 
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5. Enter 9 to the dialog box, then click OK. 
6. Now turn on the Copy Cell Data function by clicking on the  button on the toolbar.  
7. Press and hold the down arrow key ↓ to move the grid cursor from the cell [1, 1, 1] to the 

cell [1, 30, 1] on the lower-left corner of the model grid. The value of 9 is copied to all cells 
on the west side of the model. 

8. Turn on the Copy Layer Data function by clicking on the  button.  
9. Move to the second layer and the third layer. The cell values of the first layer are copied 

to the second and third layers.  
10. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To specify the horizontal hydraulic conductivity 

1. Select Parameters > Horizontal Hydraulic Conductivity to activate the Data Editor. 
2. Move to the first layer. 
3. Select Tools > Data > Reset (or press Ctrl + R) and enter 0.0001 in the dialog box, then click 

OK.  
4. Move to the second layer. 
5. Press Ctrl + R and enter 0.0005 in the dialog box, then click OK. 
6. Move to the third layer. 
7. Press Ctrl + R and enter 0.0005 in the dialog box, then click OK. 
8. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To specify the vertical hydraulic conductivity 

1. Select Parameters > Vertical Hydraulic Conductivity to activate the Data Editor. 
2. Move to the first layer. 
3. Select Tools > Data > Reset (or press Ctrl + R) and enter 0.00001 in the dialog box, then 

click OK.  
4. Move to the second layer. 
5. Press Ctrl + R and enter 0.00005 in the dialog box, then click OK. 
6. Move to the third layer. 
7. Press Ctrl + R and enter 0.00005 in the dialog box, then click OK. 
8. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To specify the effective porosity 

1. Select Parameters > Effective Porosity to activate the Data Editor. 
2. Select Tools > Data > Reset (or press Ctrl + R) to open the Reset – Aquifer Property dialog 

box. 
3. In that dialog box, enter 0.25 for Effective Porosity, select Apply to Entire Model, and then 

click OK to close the dialog box. 
4. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 
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➢ To specify the recharge rate 

1. Recharge rate may be implemented by using the Recharge Package. Select Models > 
Modflow > Package > Recharge (RCH) to activate the Data Editor. 

2. Select Tools > Data > Reset (or press Ctrl + R) and enter 8E-9 for Recharge Flux (RECH) in 
the dialog box, then click OK.  

3. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

The Recharge (RCH) menu item is now marked with , meaning that the package is now 
activated. If you need to deactivate or remove the Recharge package, right-click on the 
Input Data > Packages > Recharge item on the TOC, and then select Deactivate Package 
or Remove Package.  

➢ To specify the pumping well and its pumping rate 

The last step before running the flow model is to specify the location of the pumping well and its 

pumping rate. We can simulate the effects of pumping from a well that penetrates more than 

one layer by using the Well (WEL) Package, the Multi-Node Well (MNW1) Package, or the Multi-

Node Well 2 (MNW2) Package.  

The steps for specifying pumping data with the WEL and MNW2 packages are shown below. The 

WEL Package is used in all other sections of this tutorial. In the WEL Package, a well is 

implemented by assigning its pumping/injection rate to a cell or multiple cells. It is implicitly 

assumed that the well screen penetrates the full thickness of the cell(s). In the MNW2 Package, 

a well consists of several nodes, which can be defined by cells or by screen intervals. The MNW2 

Package partitions the flux among the various nodes connected to the multi-node well based on 

aquifer and node parameters. The effect of partial penetration of screen intervals in a cell may 

be simulated by the MNW2 Package. 

Using the Well (WEL) Package 

A multi-layer well can be simulated/approximated with the Well (WEL) Package by supplying the 

pumping rate for each layer. The total pumping rate for a multilayer well is equal to the sum of 

the pumping rates from the individual layers. The pumping rate from each layer (Qk) can be 

approximately calculated by dividing the total pumping rate (Qtotal) in proportion to the layer 

transmissivity (McDonald and Harbaugh 1988): 

Qk = Qtotal ×
Tk
∑T

 

where Tk is the transmissivity of layer k and ∑T is the sum of the transmissivities of all layers 

penetrated by the multilayer well. Unfortunately, as the first layer in this example is unconfined, 

we do not exactly know the saturated thickness and the transmissivity of this layer at the position 

of the well. The equation above cannot be used unless we assume a saturated thickness for 

calculating the transmissivity.  
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An approximation to simulate a multilayer well is to set a large vertical hydraulic conductivity (or 

vertical leakance), e.g. 1 m/s, to all cells of the well and assign the total pumping rate to the 

lowest cell of the well. For visualization purposes, a very small pumping rate (say, -1E-10 m3/s, 

remember negative value for pumping) can be assigned to other cells of the well. In this way, the 

extraction rate from each penetrated layer will be calculated by MODFLOW and can be obtained 

by using ZoneBudget (see below). Modifying the vertical hydraulic conductivity values is 

obviously a drawback of this approach.  

Since we do not know the required pumping rate for capturing the contaminated area shown in 

Figure 1, we will try a pumping rate of 0.0012 m3/s. We will use the approximation described 

above to simulate the multilayer well in the following steps.  

1. Select Models > Modflow > Packages > Well (WEL) to activate the Data Editor. 
2. Move the grid cursor to the cell [1, 15, 25] and press the Enter key to open the Well 

Package dialog box, then enter -1E-10 for Flow Rate (Q)3 in the dialog box, then click OK. 
3. Move the grid cursor to the cell [2, 15, 25] and press the Enter key to open the Well 

Package dialog box, then enter -1E-10 for Flow Rate (Q)3 in the dialog box, then click OK. 
4. Move the grid cursor to the cell [3, 15, 25] and press the Enter key to open the Well 

Package dialog box, then enter -0.0012 for Flow Rate (Q)3 in the dialog box, then click OK. 
5. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes 

made to the Well Package. 
6. Select Parameters > Vertical Hydraulic Conductivity and set the vertical hydraulic 

conductivity value to 1 for the cells [1, 15, 25], [2, 15, 25], and [3, 15, 25].  
7. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes 

made to Vertical Hydraulic Conductivity. 
 

Using the Multi-Node Well 2 (MNW2) Package 

An alternative way for simulating the multilayer well is to use the MNW2 Package in the following 

steps.  

1. Select Models > Modflow > Packages > Multi-Node Well 2 (MNW2) to activate the Data 
Editor. 

2. Move the grid cursor to the cell [1, 15, 25], press the Enter key to display the Multi-Node 
Well 2 dialog box, and then click Add to add a well to the table (Figure 6). By default, the 
new well does not have any nodes and its pumping is zero. We will need to assign nodes 
and pumping to the well.  

3. To assign pumping values to a well, double-click on the respective cell of the Pumping 
column to open the MNW2 Pumping dialog box (Figure 7), and do the following steps.  

• Click Add to add a row to the table,  

• Enter the desired pumping rate -0.0012 to the first cell of the Qdes column.  

• Keep all other settings in this dialog box unchanged as they are not used here.  

 
3 A negative value of Flow Rate (Q) means pumping. 
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• Click OK to close the dialog box.   

4. To assign nodes to a well, double-click on the respective cell of the Nodes column to open 
the MNW2 Nodes dialog box (Figure 8), and do the following steps. 

• Set Node Type to Screen Interval and Loss Type to THIEM. A multi-node well in the 
MNW2 Package must have a loss type other than NONE.  

• Click Add to add a row to the table and enter the values as given in Figure 8. We 
assume that the well is screened over all layers, and therefore 10 and 0 are assigned 
to Ztop and Zbotm (top and bottom of the screen interval), respectively. Rw is set to 
an arbitrary value of 1. A larger value of Rw will decrease the linear aquifer loss 
coefficient used by the THIEM loss type.  

• Keep all other settings in this dialog box unchanged as they are not used here.  

• Click OK to close the dialog box. 

5. Click OK in the Multi-Node Well 2 dialog box to close it. 
6. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes 

made to the MNW2 Package. 
 

 
 

 

Figure 6. The Multi-Node Well 2 dialog box 

Figure 7. The MNW2 Pumping dialog box 
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➢ To carry out the flow simulation with MODFLOW 

1. Select Models > MODFLOW > Run to open the Run Modflow dialog box (Figure 9). This 
dialog box shows the packages and the respective input file names. The checkbox of each 
row indicates whether the input file will be built (or re-built). Usually, PM sets the check 
boxes automatically and you do not need to worry about their states. 

2. Click Run to start the flow simulation. PM will use the user-specified data to generate 
input files for MODFLOW. Input data files for the Output Control and the Preconditioned 
Conjugate Gradient solver are also created with default values. As soon as the model input 
files are generated, PM starts MODFLOW, and the simulation progress will be displayed 
in the MODFLOW Output dialog box. The simulation for this model should be completed 
in a fraction of a second. For models with longer simulation time, you may terminate a 
simulation by clicking on the Terminate button on MODFLOW Output dialog box. 

3. Once the simulation is completed or terminated, click the Close button of the MODFLOW 
Output window.  

 

 

Figure 8. The MNW2 Nodes dialog box 

Figure 9. The Run Modflow dialog box 
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1.4. Review and Visualize Model Results 

In this section we will review the model run listing file, create water budget, visualize model 

results, and delineate the capture zone of the pumping well.   

1.4.1. Review Model Run Listing File 

During a flow simulation, MODFLOW saves detailed records to the run listing file (modflow.list), 

including a volumetric water budget for the entire model at the end of each time-step. Continuity 

should exist for the total flows into and out of the entire model or any sub-region of the model. 

This means that the difference between total inflow and total outflow should theoretically equal 

to 0 for a steady-state flow simulation or equal to the total change in storage for a transient flow 

simulation. The water budget provides an indication of the overall acceptability of the numerical 

solution. If the accuracy is insufficient, a new run should be done using a smaller convergence 

criterion in the iterative solver. The run listing file may contain other essential information. In 

case of difficulties in obtaining satisfactory model results, this information could be very helpful. 

➢ To review model run listing file 

1. Select Models > Modflow > View > Run Listing File to open the modflow.list file in a text 
editor (you can change the default text editor by File > Preferences).  

2. Carefully review the file, especially the volumetric water budget for the entire model at 
the end of each time-step. If the model run is not finished successfully, error message(s) 
may be saved in the file. For comparison, the end of your modflow.list file should look like 
Figure 10 if the WEL Package was used.  

3. After reviewing the run listing file, do not forget to close the text editor application. 
 

1.4.2. Create Water Budget 

There are situations in which it is useful to calculate flow terms for various zones (i.e., subregions) 

within the model domain. To enable such calculations, MODFLOW saves the computed flow 

terms for individual cells in the cell-by-cell budget file (modflow.flow). ZoneBudget is a program 

that reads the flow terms from the cell-by-cell budget file and produces water budgets for user-

defined zones within the model domain. The zones are defined by assigning zone numbers to 

model cells. Zone numbers from 0 to 999 are allowed. The number 0 indicates that a cell is not 

associated with any zone and will be excluded from the zone budget calculation. 

In the following steps, we will assign zone number 1 to the well in the first model layer, 2 to the 

well in the second layer, 3 to the well in the third layer, and 0 to all other cells. We will use the 

ZoneBudget program to calculate water budget for those zones. After the calculation is finished, 

we will review the results. 
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➢ To create water budget with ZoneBudget 

1. Select Models > ZoneBudget > Zones to activate the Data Editor. 
2. The entire model is set to zone number 1 by default. We will assign zone number 0 to the 

model in these steps: 

• Select Tools > Data > Reset (or press Ctrl + R) to open the Reset – Aquifer Property 
dialog box. 

• In that dialog box, enter 0 for Zone Numbers, select Apply to Entire Model, and then 
click OK to close the dialog box. Zone number 0 is now assigned to the model. 

3. Move to the first layer and then move the grid cursor to the cell [1, 15, 25], i.e., where 
the well is located. 

4. Press Enter and enter 1 for Zone Number in the dialog box, then click OK.  
5. Move the grid cursor to the cell [2, 15, 25] in the second layer, and then Press Enter and 

enter 2 for Zone Number in the dialog box, then click OK. 
6. Move the grid cursor to the cell [3, 15, 25] in the third layer, and then Press Enter and 

enter 3 for Zone Number in the dialog box, then click OK. 
7. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 
8. Select Models > ZoneBudget > Run to start the ZoneBudget program. The calculation will 

start automatically, and its progress will be displayed in the ZoneBudget Output window. 
You may terminate the calculation at any time by clicking on the Terminate button on 

  VOLUMETRIC BUDGET FOR ENTIRE MODEL AT END OF TIME STEP    1, STRESS PERIOD   1 

  ------------------------------------------------------------------------------ 

 

     CUMULATIVE VOLUMES      L**3       RATES FOR THIS TIME STEP      L**3/T 

     ------------------                 ------------------------ 

           IN:                                      IN: 

           ---                                      --- 

             STORAGE =           0.0000               STORAGE =           0.0000 

       CONSTANT HEAD =      209430.2188         CONSTANT HEAD =       2.2121E-03 

               WELLS =           0.0000                 WELLS =           0.0000 

            RECHARGE =      254480.4844              RECHARGE =       2.6880E-03 

 

            TOTAL IN =      463910.6875              TOTAL IN =       4.9001E-03 

 

          OUT:                                     OUT: 

          ----                                     ---- 

             STORAGE =           0.0000               STORAGE =           0.0000 

       CONSTANT HEAD =      349174.0312         CONSTANT HEAD =       3.6882E-03 

               WELLS =      113607.3906                 WELLS =       1.2000E-03 

            RECHARGE =           0.0000              RECHARGE =           0.0000 

 

           TOTAL OUT =      462781.4375             TOTAL OUT =       4.8882E-03 

 

            IN - OUT =        1129.2500              IN - OUT =       1.1928E-05 

 

 PERCENT DISCREPANCY =           0.24     PERCENT DISCREPANCY =           0.24 

 

         TIME SUMMARY AT END OF TIME STEP    1 IN STRESS PERIOD    1 

                    SECONDS     MINUTES      HOURS       DAYS        YEARS 

                    ----------------------------------------------------------- 

   TIME STEP LENGTH 9.46728E+07 1.57788E+06  26298.      1095.8      3.0000     

 STRESS PERIOD TIME 9.46728E+07 1.57788E+06  26298.      1095.8      3.0000     

         TOTAL TIME 9.46728E+07 1.57788E+06  26298.      1095.8      3.0000     

 

Figure 10. Volumetric budget of the model 
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that window. Once the calculation is finished or terminated, close the ZoneBudget Output 
window by clicking on its Close button.  

9. Review the results 

• Models > ZoneBudget > View > Listing File: This listing file contains the water budget 
of all zones of individual time steps at which flow terms are saved in the budget file. 

• Models > ZoneBudget > View > CSV File: For each time, for which the flow terms are 
saved in the budget file, there is one line for each in-flow term and each out-flow term 
along with totals. The zones are displayed in columns, so one table displays all zones. 
This makes it easy to compare any budget term for all the different zones. The CSV file 
is formatted in the way suitable to be loaded into a spreadsheet application. If the 
WEL Package was used, the CSV file should look like Figure 11. If the MNW2 Package 
was used, the CSV file should look like Figure 12. The highlighted line in Figure 11 
contain the flow rates from zone 0 to zones 1, 2, and 3, respectively. It means that the 
pumping well is extracting 7.647932E-05 m3/s from the first layer, 5.546326E-04 m3/s 
from the second layer, and 5.531944E-04 m3/s from the third layer. Figure 12 shows 
similar results when using the MNW2 Package in the simulation. In addition, 
MODFLOW also saves the nodal fluxes of MNW2 nodes in the 
modflow_mnwi_bynode.txt file (located in the model data folder).  

• Models > ZoneBudget > View > CSV2 File: The CSV2 file displays the complete budget 
for one zone and one time in a single line. Each column has a separate inflow or 
outflow budget term. The rows can be sorted by time within the spreadsheet 
program, which makes it possible to easily see how each term changes with time. The 
CSV2 file is formatted in the way suitable to be loaded into a spreadsheet application.  

 

 

Time Step,  1,Stress Period,  1,  

                ,  ZONE   1      ,  ZONE   2      ,  ZONE   3      , 

                ,    IN          ,    IN          ,    IN          , 

   CONSTANT HEAD,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

           WELLS,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

        RECHARGE,    3.200000E-06,    0.000000E+00,    0.000000E+00, 

   FROM ZONE   0,    7.647932E-05,    5.546326E-04,    5.531944E-04, 

   FROM ZONE   1,    0.000000E+00,    7.729365E-05,    0.000000E+00, 

   FROM ZONE   2,    0.000000E+00,    0.000000E+00,    6.360837E-04, 

   FROM ZONE   3,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

Total IN        ,    7.967932E-05,    6.319262E-04,    1.189278E-03, 

                ,   OUT          ,   OUT          ,   OUT          , 

   CONSTANT HEAD,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

           WELLS,    1.000000E-10,    1.000000E-10,    1.200000E-03, 

        RECHARGE,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

     TO ZONE   0,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

     TO ZONE   1,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

     TO ZONE   2,    7.729365E-05,    0.000000E+00,    0.000000E+00, 

     TO ZONE   3,    0.000000E+00,    6.360837E-04,    0.000000E+00, 

Total OUT       ,    7.729375E-05,    6.360838E-04,    1.200000E-03, 

 IN-OUT         ,    2.385568E-06,   -4.157604E-06,   -1.072193E-05, 

Percent Error   ,    3.039462E+00,   -6.557683E-01,   -8.975038E-01,  

Figure 11. The ZoneBudget.CSV file (when simulated with the WEL Package) 
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1.4.3. Visualize Model Results 

PM provides several tools for visualizing model input parameters and model results. A model 

item on the TOC contains two major groups, namely Input Data and Visualization. The former can 

be used to adjust visualization settings of the model grid, flow packages, and observation points. 

The latter includes Input Parameter Contours, Result Contours, Flow Vectors, and MODPATH that 

can be used to create visual objects based on the model input data or results. 

In this section, we will add a contour map (based on the calculated hydraulic head values), add 

flow vectors (based on the calculated head values and cell-by-cell flow terms), and then add the 

capture zone of the pumping well to the Map Viewer.  

➢ To create hydraulic head contours 

1. Right-click on Visualization > Result Contours of the model item on the TOC and select 
Add from the popup menu. The Select Data dialog box is displayed.  

2. Click OK to accept the default data type “Hydraulic Head” and close the dialog box. PM 
will add an item, called “Hydraulic Head [L]”, to the TOC, and will display the hydraulic 
head contours on the Map Viewer. The settings of this item are displayed in the Settings 
window. The hydraulic head contours in Layer 1 should look like Figure 13.  

3. You may click on the “Hydraulic Head [L]” item and adjust its display with the controls on 
the settings window. For example, Figure 14 shows the color-filled contours with a larger 
font size for contour labels. See User Guide of PM for details about the available settings.  

4. You may right-click on the “Hydraulic Head [L]” item on the TOC to display its popup menu 
that will allow you to export the contour map to a shapefile, export its data, or remove it. 

Time Step,  1,Stress Period,  1 

                ,  ZONE   1      ,  ZONE   2      ,  ZONE   3      , 

                ,    IN          ,    IN          ,    IN          , 

   CONSTANT HEAD,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

        RECHARGE,    3.200000E-06,    0.000000E+00,    0.000000E+00, 

            MNW2,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

   FROM ZONE   0,    7.510666E-05,    5.482526E-04,    5.473648E-04, 

   FROM ZONE   1,    0.000000E+00,    2.019779E-06,    0.000000E+00, 

   FROM ZONE   2,    0.000000E+00,    0.000000E+00,    7.341887E-07, 

   FROM ZONE   3,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

Total IN        ,    7.830666E-05,    5.502723E-04,    5.480990E-04, 

                ,   OUT          ,   OUT          ,   OUT          , 

   CONSTANT HEAD,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

        RECHARGE,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

            MNW2,    7.568417E-05,    5.627775E-04,    5.615383E-04, 

     TO ZONE   0,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

     TO ZONE   1,    0.000000E+00,    0.000000E+00,    0.000000E+00, 

     TO ZONE   2,    2.019779E-06,    0.000000E+00,    0.000000E+00, 

     TO ZONE   3,    0.000000E+00,    7.341887E-07,    0.000000E+00, 

Total OUT       ,    7.770395E-05,    5.635117E-04,    5.615383E-04, 

 IN-OUT         ,    6.027099E-07,   -1.323937E-05,   -1.343930E-05, 

Percent Error   ,    7.726524E-01,   -2.377367E+00,   -2.422288E+00,  

Figure 12. The ZoneBudget.CSV file (when simulated with the MNW2 Package) 
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Figure 13. Hydraulic head contours of Layer 1 

Figure 14. Color-filled hydraulic head contours of Layer 1 
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➢ To create flow vectors 

1. Right-click on Visualization > Flow Vectors of the model item on the TOC and select Add 
from the popup menu. PM will add an item, called “Flow Vectors”, to the TOC, and will 
display the flow vectors on the Map Viewer. The flow vectors in Layer 1 should look like 
Figure 15.  

2. You may adjust the display of the newly added item by using its Settings window. See 
User Guide of PM for details about the available settings.  

3. You may right-click on the “Flow Vectors” item on the TOC to display its popup menu that 
will allow you to export the flow vectors to a shapefile or remove it.  

 

 

➢ To delineate the capture zone of a pumping well by backward particle tracking 

1. Right-click on Visualization > MODPATH of the model item on the TOC and select Add 
from the popup menu. PM will add an item, called “Modpath Instance”, to the TOC. 
Initially, this new instance does not have any visual representations and its particle 
tracking direction is set as Forward by default. 

2. To delineate a capture zone, we need to switch the particle tracking direction to Backward 
in these steps: 

• Click on the newly added MODPATH instance 

• In the Settings window of this MODPATH instance, set Tracking Direction to Backward. 

• Set the value for Time Point Interval to 94672800 [seconds]. 

Figure 15. Flow Vectors and color-filled hydraulic head contours 
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• Note that the default setting of RCH Face assigns the recharge flux on the top face of 
model cells. 

3. We will now add new particles to the MODPATH instance in the following steps. Particles 
(i.e., starting points of pathlines) may be released at different time points. The release 
time of a particle is defined based on tracking direction when the particle is added. For 
forward tracking, the release time of new particles is set to the beginning of the current 
time step and stress period. For backward tracking, the release time is set to the end of 
the current time step and stress period. Once particles are added to the map, their release 
times, start locations, and display colors are fixed. 

• Click the MODPATH instance to make it the active layer and then click on the 
MODPATH Tool button  on the toolbar. 

• Move to the second layer (by using the  and/or  buttons on the toolbar). 

• Place the mouse cursor at a corner of the cell [2, 15, 25] containing the pumping well, 
then hold down the left mouse button and drag the mouse to draw a box until it 
covers the center of the cell. 

• Release the left mouse button. The Add Particles dialog box appears. Assign the 
settings and numbers of particles to the dialog box as shown in Figure 16. When 
finished, click OK to close the dialog box.  

• Move to the third layer (by using the  button on the toolbar) and repeat the steps 
above to add particles with another color to this layer.  

• Once all particles are added, click Run in the Settings window of the MODPATH 
instance to start MODPATH. The calculation will start automatically, and its progress 
will be displayed in the MODPATH Output window. When the simulation is finished, 
Close the MODPATH Output window by clicking on its Close button. 

• Once the simulation is finished, PM will display the (projection of) pathlines on the 
Map Viewer (Figure 17). The black dots are the end points of pathlines. The yellow 
dots along pathlines are particle tracking time points with the interval defined in the 
settings window.  

• Click on the  button on the toolbar to display the Row Cross Section window. On the 
Row Cross Section Window, set Exaggeration to 15 and then click the  button to 
zoom out. As the recharge term is applied to the cell top, some pathlines track back 
to the groundwater surface where recharge was applied (Figure 18). The results of 
backward particle tracking indicate that the capture zone of the pumping well 
adequately covers the contaminated area.  

4. Click the X button located on the upper-right corner of the Row Cross Section Window to 
close it and then uncheck this MODPATH instance on the TOC to hide the pathlines. 
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Figure 16. Adding particles on circles with the Add Particles dialog box 

Figure 17. Projection of pathlines on the Map Viewer (backward tracking) 
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➢ To run forward particle tracking 

In the following steps, we will add particles on the groundwater surface within the contaminated 

area and create pathlines with forward particle tracking. If the pumping rate of our well is 

adequately high, all pathlines should terminate at the well. 

1. Right-click on Visualization > MODPATH of the model item on the TOC and select Add 
from the popup menu. PM will add a new “Instance” item to the TOC.  

2. In the Settings window of this MODPATH instance, set the value for Time Point Interval 
to 94672800 [seconds]. 

3. We will now add new particles (i.e., starting points of pathlines) to the MODPATH instance 
in the following steps.  

• Click the MODPATH instance to make it the active layer and then click on the 
MODPATH Tool button  on the toolbar. 

• Move to the first layer. 

• Place the mouse cursor at upper-left corner of the cell [1, 12, 6]4, then hold down the 
left mouse button and drag the mouse to the lower-right corner of the cell [1, 18, 11] 
to draw a box covering the contaminated area. 

 
4 the cell location of the mouse cursor is displayed on the status bar of PM’s main window. 

Figure 18. Projection of pathlines on Row Cross Section Window (backward tracking) 
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• Release the left mouse button. The Add Particles dialog box appears. Assign the 
settings and numbers of particles to the dialog box as shown in Figure 19. 

4. Click Run in the Settings window of the MODPATH instance to start MODPATH. When the 
simulation is finished, Close the MODPATH Output window by clicking on its Close button. 

5. As soon as the calculation is finished, PM will display the (projection of) pathlines on the 
Map Viewer (Figure 20). By clicking on  button on the toolbar, you can display the 
(projection of) pathlines on the Row Cross Section window (Figure 21). The figures show 
that the contaminates originated from contaminated area will all end up at the well. Note 
that MODPATH is an advective transport model and does not include the effects of 
dispersion and/or chemical reaction.  

6. Click the X button located on the upper-right corner of the Row Cross Section Window to 
close it and then uncheck this MODPATH instance on the TOC to hide the pathlines. 

Figure 19. Adding particles on cell faces with the Add Particles dialog box 
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Figure 20. Projection of pathlines on the Map Viewer (forward tracking) 

Figure 21. Projection of pathlines on the Row Cross Section Window (forward tracking) 
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1.5. Parameter Estimation with PEST 

The parameter estimation (calibration) of a flow model is accomplished by finding a set of 

parameters, hydrologic stresses, or boundary conditions so that the simulated values match the 

measurement values to a reasonable degree. 

To demonstrate the use of the parameter estimation program PEST within PM, we assume that 

the horizontal hydraulic conductivity (HK) in the third layer is homogeneous, but its value needs 

to be estimated. We have four observation points in the third layer. Their names, geographic 

coordinates and measured head values are given in Table 1 below.  

Table 1. The observation points and observed head values 

Observation Point Layer Latitude Longitude Head 

h1 3 33.673303 -117.745125 8.23 

h2 3 33.670994 -117.748532 8.84 

h3 3 33.674042 -117.748392 8.82 

h4 3 33.671545 -117.746009 8.45 

In the following, we will enter the observation points and head values, set HK in the third layer 

as an estimable parameter, configure PEST settings, and then run PEST.  

➢ To specify the observation boreholes and observed head values 

1. Move to the third layer. 
2. Right-click on Input Data > Observation Points of the model item on the TOC and select 

Edit Data from the popup menu to display the Observation dialog box (Figure 22). When 
the dialog box is opened the first time, its tables are empty. 

3. The Observation Point group on the left-hand side of the dialog box displays the 
observation points and their properties. Click the Add button of this group four times to 
add four observation points to the table. New observation points are set as single layer 
observations and assigned to the current layer (third layer).  

4. Enter the names and coordinates of the observation points as shown in Figure 22. 
5. To enter the observed head value for the point h1, click on its record on the Observation 

Point table, and follow these steps to enter its observed values to the Observations group:  

• Make sure that Type is set to Hydraulic Head. 

• Click the Add button to add a record to the Observation table and enter the values as 
shown in Figure 22. Time is set to 94672800 because for a steady-state model PEST is 
instructed to compare the results at the end of the simulation with the observed 
values.  

6. Repeat Step 3 to enter observed head values for other points.  
7. Click OK to close the dialog box. This completes the data entry of the observation points 

and observed values. Instead of keying in data, you may also import/export observation 

data from/to Excel files. You may also use the Observation Tool  to enter observation 
points. Refer to the User Guide of PM for details.  
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➢ To set HK in the third layer as an estimable parameter 

1. Select Parameters > Horizontal Hydraulic Conductivity to activate the Data Editor. 
2. Move to the third layer. 
3. Select Tools > Data > Reset (or press Ctrl + R), enter 1 for Parameter Number and 0.0005 

for Horizontal Hydraulic Conductivity, then click OK. HK of the third layer is now set as 
parameter #1 with the initial guessed value of 0.0005. 

4. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To configure PEST settings 

1. Select Models > PEST > Settings to open the PEST Settings dialog box (Figure 23). When 
the dialog box is opened for the first time, PM will search for the estimable parameters 
and put them in the Parameters table. If you define additional estimable parameters later, 
you will need to select More Actions > Search for Parameters to add them to the table. In 
this example, a parameter named HK_1 has been added to the table with the following 
values:  

• PARNME is the parameter name. It is a combination of the short name of the 
parameter and the parameter number. For example, HK_1 stands for parameter 
number 1 of horizontal hydraulic conductivity.  

• PARVAL is the initial guess of the parameter and is set to its average value.  

• Minimum and Maximum are respectively the lower and upper bound of the 
parameter. 

• Refer to the User Guide of PM for the description of all other values. 

2. Turn on the parameter HK_1 by checking its box in the  column  
3. Click OK to accept other default settings5 and close the dialog box.  

 
5 The default setting instructs PEST to undertake a final model run with best parameters (see LASTRUN in the Control 
Data tab of the PEST Settings dialog box). 

Figure 22. The Observation dialog box 



 

  
Last Update: 7/4/2022 26 

 

➢ To run PEST 

1. Select Models > PEST > Run to display the Run PEST dialog box appears (Figure 24). PM 

will configure the settings for the build boxes in the  column automatically. 
2. Click Run to start PEST. PM will use the user-specified data to generate input files for 

MODFLOW and PEST. The parameter estimation progress will be displayed in the PEST 
Output window. You may terminate PEST at any time by clicking on the Terminate button 
on that window. 

3. Once the PEST run is finished or terminated, click the Close button of the PEST Output 
window.  

➢ To check the parameter estimation results 

During a parameter estimation process, PEST records the progress and the estimated parameter 

values to the run record file PEST.REC. PEST also writes the estimated parameters and other 

information to separate files. You can access those files by selecting items from Models > PEST > 

View.  

Figure 23. The PEST Settings dialog box 

Figure 24. The Run PEST dialog box 
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➢ To display the scatter plot of measured vs. observed head values 

1. Select Models > PEST > View > Scatter Chart > Head to display the Head Scatter Chart 
window (Figure 25).  

2. Check the “show the regression line of all displayed data points” box to display the linear 
regression line.  

3. You may use the table in this dialog box to adjust the display settings of individual points. 
For this example, the  boxes in the table have no effects because we cannot display 
regression lines of individual observation points for a steady-state model. 

4. Right-click on the chart and select Show Legend from the popup menu to display the 
legend on the chart. The regress line of all data shows a nearly perfect fit of the simulated 
and observed head values because the “observed” values in Table 1 were actually taken 
from the result of the MODFLOW simulation (from Section 1.3). You can compare the 
calculated and observed head values in the Data Tab. 

Figure 25. The Head Scatter Chart dialog box 
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1.6. Build and Run a Transport Model 

The transport of solutes in porous media can be described by three major processes: advection, 

dispersion, and chemical reactions. We will use MT3D to simulate these transport processes. The 

transport simulation is based on the flow field calculated previously by MODFLOW.  

To demonstrate the use of MT3D, we assume that the contaminant is dissolved into groundwater 

at a rate of 1x10-4 μg/s/m2. The values for longitudinal and transverse dispersivity are 10 m and 

1 m, respectively. The distribution coefficient for the linear equilibrium sorption is 0.000125. The 

bulk density of the porous medium is 2000 [kg/m3]. The initial concentration, molecular diffusion 

coefficient, and decay rate are assumed to be zero. 

In this section, we will walk you through the following steps to build your MT3D model with PM.  

1. Configure MT3D settings, 
2. Assign cell types for the transport model to model cells, 
3. Assign the bulk density values to model cells,  
4. Assign the initial concentration values to model cells,  
5. Assign input rate of contaminants, 
6. Assign parameters to the Advection Package, 
7. Assign values of longitudinal dispersivity, 
8. Assign values of transverse dispersivity, 
9. Assign values of distribution coefficient for the linear equilibrium sorption, 
10. Define output terms and output times, 
11. Carry out the transport simulation with MT3D, and 
12. Create concentration contours. 

➢ To configure MT3D settings 

1. Select Models > MT3D/SEAWAT > Settings to open the Transport Settings dialog box 
(Figure 26). We will use the transport model MT3DMS6 and its packages as shown in the 
figure.  

2. Click on the Species tab and check the box of Species #1 in the  column to activate that 
species for the transport simulation. 

3. Click on the RCT tab and make sure that  

• Sorption Type (ISOTHM) is set to Linear Isotherm, 

• Reaction Type (IREACT) is set to No Kinetic Rate Reaction, and 

• Reaction Module (IREACTION) is set to No Custom Reaction. 

4. Click OK to close the dialog box. We will accept and use other default settings. 
 

 
6 If the flow model includes any of the LAK3, SFR2, or UZF1 packages and the MODFLOW-NWT or MODFLOW-OWHM 
is used for the flow simulation, MT3D-USGS must be used instead of MT3DMS. The latter is not compatible with the 
modflow.linkmt3d file produced by the newer versions of MODFLOW when the aforementioned packages are used.  



 

  
Last Update: 7/4/2022 29 

 

➢ To assign cell types 

MT3D uses the ICBUND array, which contains a value for each model cell. A positive value in the 

ICBUND array defines an active concentration cell where the solute concentration is computed; 

A negative value defines a constant concentration cell; and the value 0 defines an inactive 

concentration cell. It is recommended to use 1 for active, -1 for constant, and 0 for inactive 

concentration cells. Variable-head cells may be treated as inactive concentration cells to 

minimize the area needed for transport simulation, if the solute concentration is insignificant 

near those cells. Follow the steps below to assign the values to the ICBUND array. 

1. Select Discretization > ICBUND (Transport) to activate the Data Editor. As all model cells 
are set to active transport cell by default, we do not need to modify the cell types. 

2. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To assign bulk density values 

1. Select Parameters > Bulk Density to activate the Data Editor. 
2. Select Tools > Data > Reset (or press Ctrl + R) to open the Reset – Aquifer Property dialog 

box. 
3. In that dialog box, enter 2000 for Bulk Density, select Apply to Entire Model, and then 

click OK to close the dialog box. 
4. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

Figure 26. The Transport Settings dialog box 
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➢ To assign initial concentration values 

1. Select Models > MT3D/SEAWAT > Initial Concentration to activate the Data Editor. The 

dropdown box next to  on the toolbar shows Species #1 indicating that the data of 
species #1 is being edited.  

2. The initial concentration values are set to zero by default. For this example, we will accept 
the default setting and do not need to modify the concentration values.  

3. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To assign input rate of contaminants 

1. Select Models > MT3D/SEAWAT > Packages > Sink/Source Mixing (SSM) > Recharge (RCH) 
to activate the Data Editor. 

2. Assign 12500 [μg/m3] to the cells within the contaminated area. This value is the 
concentration associated with the recharge flux. The product of the recharge rate 
8 x 10-9 [m3/m2/s] and the associated concentration 12500 [μg/m3] yields the desired 
dissolution rate of 1 x 10-4 [μg/s/m2] (= 8 x 10-9 x 12500). 

3. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To assign parameters to the Advection Package 

1. Select Models > MT3D/SEAWAT > Packages > Advection (ADV) to open the Advection 
Package dialog box (Figure 27). 

2. Enter the values and settings as shown in Figure 27. 
3. Click OK to close the dialog box. 
 

Figure 27. The Advection dialog box 
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➢ To assign values of longitudinal dispersivity 

1. Select Models > MT3D/SEAWAT > Packages > Dispersion (DSP) > Longitudinal Dispersivity 
to activate the Data Editor. 

2. Select Tools > Data > Reset (or press Ctrl + R) to open the Reset – Aquifer Property dialog 
box. 

3. In that dialog box, enter 10 for Longitudinal Dispersivity, select Apply to Entire Model, and 
then click OK to close the dialog box. 

4. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ To assign values of transverse dispersivity 

In MT3D, the transverse dispersivity is defined as a ratio of the longitudinal dispersivity. The 

values of the ratio are given as TRPV and TRPT in the Layer Property dialog box (Figure 5), 

where TRPT is the ratio of the horizontal transverse dispersivity to the longitudinal 

dispersivity and TRPV the ratio of the vertical transverse dispersivity to the longitudinal 

dispersivity. For this example, we accept the default values of 0.1 for TRPT and set the values 

of TRPV to 0.1. 

➢ To assign values of distribution coefficient for the linear equilibrium sorption 

1. Select Models > MT3D/SEAWAT > Packages > Reaction (RCT) > Distribution Coefficient to 
activate the Data Editor. 

2. Select Tools > Data > Reset (or press Ctrl + R) to open the Reset – Aquifer Property dialog 
box. 

3. In that dialog box, enter 0.000125 for Distribution Coefficient, select Apply to Entire 
Model, and then click OK to close the dialog box. 

4. Select Tools > Finish Edit (or press Ctrl + F) to stop the Data Editor and save the changes. 

➢ Define output terms and output times. 

1. Select Models > MT3D/SEAWAT > Output Control to display the Output Control 
(MT3D/SEAWAT) dialog box. 

2. In the Output Options tab, make sure that SAVUCN is checked and NPRS is set to 1.  
3. In the Output Times tab, set Start Time to 0, End Time to 94672800, Interval to 3000000, 

and then click Apply. This instructs MT3D to save simulation results at the time points 
defined in the Output Time table. 

4. Click OK to close the dialog box. 

➢ To carry out the transport simulation with MT3D 

1. Select Models > MT3D/SEAWAT > Run to display the Run MT3D dialog box (Figure 28). 

2. PM will configure the settings for the build boxes in the  column automatically. 
3. Click Run to start MT3D. PM will use the user-specified data to generate input files for 

MT3D and then start MT3D. The simulation progress will be displayed in the MT3D Output 
window. You may terminate MT3D at any time by clicking on the Terminate button on 
that window. 



 

  
Last Update: 7/4/2022 32 

 

4. Once the MT3D run is finished or terminated, click the Close button of the MT3D Output 
window.  

➢ To create concentration contours 

1. Right-click on Visualization > Result Contours of the model item on the TOC and select 
Add from the popup menu. The Select Data dialog box is displayed.  

2. Set Data Type to Concentration, Species to species #1, Phase to Dissolved, and then Click 
OK to close the dialog box.  

3. PM will add an “Concentration [M/L^3]” item to the TOC and will display the contours on 
the Map Viewer using the calculated concentration values at the end of the current time 
step and stress period. The contours in Layer 1 should look like Figure 29. You may use 
the Settings window to use the concentration values at another time point. 

4. You may adjust the display of the newly added item by using its Settings window. For 
example, Figure 30 shows the color-filled contours with a larger font size for contour 
labels and modified contour levels. See User Guide of PM for details about the available 
settings. Note that you can uncheck the previously created items in the Visualization 
group on the TOC to hide them. 

5. You may right-click on the “Concentration [M/L^3]” item to display its popup menu that 
will allow you to export its data, export its contour map to a shapefile, or remove it.  

Figure 28. The Run MT3D dialog box 
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Figure 29. The concentration contours in Layer 1 

Figure 30. Color-filled concentration contours in Layer 1 
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➢ To create line chart of concentration values at observation points 

In the following steps, we will add two observation points in the cells [2, 15, 15] and [2, 15, 
20] with the Observation tool, and then display the line chart based on the simulated 
concentration time series at those two points. 
1. Move to the second layer. 

2. Activate the Observation tool by clicking on the  button on the toolbar. The mouse 

cursor should look like  when it is inside the Map Viewer. 
3. Move the mouse cursor to the center of the cell [2, 15, 15] and left-click once to set an 

observation point. A unique (random) name is assigned to that observation point. 
4. Move the mouse cursor to the center of the cell [2, 15, 20] and left-click once to set an 

observation point. A unique (random) name is assigned to that observation point. 
5. Now we need to turn off the head observation points and assign meaningful names to the 

newly added points: 

• Right-click on Input Data > Observation Points of the model item on the TOC and select 
Edit Data from the popup menu to display the Observation dialog box. 

• Turn of the observation points h1, h2, h3, and h4 by unchecking their boxes in the  
column. 

• Change the names and labels of the point in cell [2, 15, 15] to “c1” and the point in 
cell [2, 15, 20] to “c2”.  

• Click OK in the Observation dialog box to close it. 

6. Select Models > MT3D/SEAWAT > View > Line Chart to display the Concentration Line 
Chart dialog box (Error! Reference source not found.). If your model has more than one 
species, you can use the Species dropdown box on the lower-left corner to select a species 
of interest. The calculated data are displayed in the Data Tab.  

7. In the Concentration Line Chart dialog box, click OK to close it. 
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1.7. Animation 

You already learned how to create contour maps of calculated head and concentration values. 

Those images are static and ideal for paper-based reports or slide-based presentations. In many 

cases, however, these static images cannot ideally illustrate the motion of concentration plumes 

or temporal variation of hydraulic heads or drawdowns. Although the animation process requires 

relatively large amount of computer resources to read, process and display the data, the effect 

of a motion picture is often very helpful. 

The following steps show how to create an animation sequence for displaying the motion of the 

concentration plume in the third layer. 

Figure 31. The Concentration Line Chart dialog box 
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➢ To create an animation sequence 

1. Select File > Animation to open the Animation dialog box (Figure 32) 
2. Assign the settings to the dialog box as shown in Figure 32.  

3. Click the  button to start the animation. PM will create an image for each time point 
from Start to End as defined by the Time Control settings. You may stop the animation by 

clicking the  button. 

4. To run Animation backwards from End to Start, click the  button.  
5. If you want to record an animation sequence, configure the settings in Recording Options 

before clicking the  or  button. If you want to freeze a certain visualization item (for 
example, head contours) at a given time point, configure its Sync parameters in the 
Settings window before opening the Animation dialog box.   

1.8. Save Your Model 

This concludes the tutorial. Select File > Save or press Ctrl + S to save your PM file. You can open 

the PM file later by selecting File > Open or selecting the filename from File > Recent Files.  

Figure 32. The Animation dialog box 
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